SlideShare a Scribd company logo
Basic Cisco Commands
By Marcus Nielson (2014)
Configuring Basic Switch Settings (Switch Examples)
Enter enable if the prompt has changed back to Switch>.
Switch> enable
Switch#
Enter global configuration mode.
Switch# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#
The prompt changed again to reflect global configuration mode.
Assign the switch hostname.
Switch(config)# hostname S1
S1(config)#
Configure password encryption.
S1(config)# service password-encryption
S1(config)#
Assign class as the secret password for privileged EXEC mode access.
S1(config)# enable secret class
S1(config)#
Prevent unwanted DNS lookups.
S1(config)# no ip domain-lookup
S1(config)#
Configure a MOTD banner.
S1(config)# banner motd #
Enter Text message. End with the character ‘#’.
Unauthorized access is strictly prohibited. #
Verify your access settings by moving between modes.
S1(config)# exit
S1#
*Mar 1 00:19:19.490: %SYS-5-CONFIG_I: Configured from console by console
S1# exit
S1 con0 is now available.
Creating/Assigning a VLAN IP Address Example:
S1(config)# vlan 99
S1(config-vlan)# name (name of VLAN)
S1(config-vlan)# exit
S1(config)#
Configure the VLAN 99 IP address:
S1(config)# interface vlan 99
S1(config-if)# ip address 172.16.99.11 255.255.255.0
S1(config-if)# no shutdown
S1(config-if)# end
S1#
Configuring IP Default Gateway:
S1(config)# ip default-gateway 192.168.1.1
S1(config)#
Restrict Access:
S1(config)# line con 0
S1(config-line)# password (pw)
S1(config-line)# login
S1(config-line)# logging synchronous
S1(config-line)# exit
S1(config)#
VTY:
S1(config)# line vty 0 15
S1(config-line)# password (pw)
S1(config-line)# login
S1(config-line)# end
S1#
Assign ports F0/5 and F0/6 to VLAN 99 on the switch:
S1# config t
S1(config)# interface f0/5
S1(config-if)# switchport mode access
S1(config-if)# switchport access vlan 99
S1(config-if)# interface f0/6
S1(config-if)# switchport mode access
S1(config-if)# switchport access vlan 99
S1(config-if)# end
Assigning ports to VLAN (range):
S1(config)# interface range f0/1 – 24,g0/1 - 2
S1(config-if-range)# switchport access vlan #
S1(config-if-range)# exit
S1(config)# end
Configure and Verify SSH:
S1(config)# line vty 0 15
S1(config-line)# transport input ssh
S1(config-line)# login local
S1(config-line)# exit
Generate an RSA crypto keys:
S1(config)# crypto key generate rsa modulus 1024
Configure general security features:
S1(config)# interface range f0/1 – 4
S1(config-if-range)# shutdown
S1(config-if-range)# interface range f0/7 – 24
S1(config-if-range)# shutdown
S1(config-if-range)# interface range g0/1 – 2
S1(config-if-range)# shutdown
S1(config-if-range)# end
S1#
Enter local passwords:
S1(config)# enable secret class
S1(config)# line con 0
S1(config-line)# password (pw)
S1(config-line)# login
S1(config-line)# exit
S1(config)#
Configure a trunk port:
S2(config)# interface f0/1
S2(config-if)# switchport mode trunk
S1# show interface trunk
Configuring 802.1Q Trunk-Based Inter-VLAN Routing:
S1(config)# vlan 10
S1(config-vlan)# name Students
S1(config-vlan)# vlan 20
S1(config-vlan)# name Faculty
S1(config-vlan)# exit
S1(config)# interface f0/1
S1(config-if)# switchport mode trunk
S1(config-if)# interface f0/5
S1(config-if)# switchport mode trunk
S1(config-if)# interface f0/6
S1(config-if)# switchport mode access
S1(config-if)# switchport access vlan 10
Configure DHCPv4 :
S1(config)# ip dhcp excluded-address 192.168.1.1 192.168.1.10
S1(config)# ip dhcp pool DHCP1
S1(dhcp-config)# network 192.168.1.0 255.255.255.0
S1(dhcp-config)# default-router 192.168.1.1
S1(dhcp-config)# dns-server 192.168.1.9
S1(dhcp-config)# lease 3
Configure DHCPv4 for Multiple VLANs:
S1(config)# interface f0/6
S1(config-if)# switchport access vlan 2
S1(config)# ip dhcp excluded-address 192.168.2.1 192.168.2.10
S1(config)# ip dhcp pool DHCP2
S1(dhcp-config)# network 192.168.2.0 255.255.255.0
S1(dhcp-config)# default-router 192.168.2.1
S1(dhcp-config)# dns-server 192.168.2.9
S1(dhcp-config)# lease 3
Enable IP Routing:
S1(config)# ip routing
S1(config)# ip route 0.0.0.0 0.0.0.0 192.168.1.10
R1(config)# ip route 192.168.2.0 255.255.255.0 g0/1
Enable spanning-tree, rapid-pvst, portfast:
S1(config)# spanning-tree vlan 1,10,99 root secondary
S1(config)# spanning-tree mode rapid-pvst
S1(config)# interface f0/6
S1(config-if)# spanning-tree portfast
S1(config-if)# spanning-tree bpduguard enable
Configure PAgP:
S1(config)# interface range f0/3-4
S1(config-if-range)# channel-group 1 mode desirable
Creating a port-channel interface Port-channel 1
S1(config-if-range)# no shutdown
Configure trunk ports assign to VLAN:
S1(config)# interface port-channel 1
S1(config-if)# switchport mode trunk
S1(config-if)# switchport trunk native vlan 99
Delete the VLAN database:
S1# delete vlan.dat
Delete filename [vlan.dat]?
Delete flash:/vlan.dat? [confirm]
S1#
Configuring Basic Router Settings (Router Examples) ==========================
Configure the router:
Router> enable
Router#
Router# config terminal
Router(config)#
Router(config)#	
  hostname	
  R1.	
  	
  
R1(config)#	
  no	
  ip	
  domain-­‐lookup	
  
	
  R1(config)#	
  security	
  passwords	
  min-­‐length	
  10	
  	
  	
  
R1(config)#	
  enable	
  secret	
  cisco12345	
  
Setting a console password on a router:
R1(config)# line con 0
R1(config-line)# password ciscoconpass
R1(config-line)# exec-timeout 5 0
R1(config-line)# login
R1(config-line)# logging synchronous
R1(config-line)# exit
R1(config)#
Assign VTY password:
R1(config)# line vty 0 4
R1(config-line)# password ciscovtypass
R1(config-line)# exec-timeout 5 0
R1(config-line)# login
R1(config-line)# logging synchronous
R1(config-line)# exit
R1(config)#
Encrypt the clear text passwords:
R1(config)# service password-encryption
Create a MOTD banner:
R1(config)# banner motd #Unauthorized access prohibited!#
Configure an IP address and interface description. Activate both interfaces on the router:
R1(config)# int g0/0
R1(config-if)# description Connection to PC-B
R1(config-if)# ip address 192.168.0.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# int g0/1
R1(config-if)# description Connection to S1
R1(config-if)# ip address 192.168.1.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# exit
Configure the router for SSH access:
R1# configure terminal
R1(config)# ip domain-name CCNA-lab.com
R1(config)# username admin privilege 15 secret adminpass1
R1(config)# line vty 0 4
R1(config-line)# transport input ssh
R1(config-line)# login local
R1(config-line)# exit
R1(config)# crypto key generate rsa modulus 1024
R1(config)# exit
Configure IPv6:
R1# configure terminal
R1(config)# interface g0/0
R1(config-if)# ipv6 address 2001:db8:acad:a::1/64
R1(config-if)# ipv6 address fe80::1 link-local
R1(config-if)# no shutdown
R1(config-if)# exit
R1(config)# ipv6 unicast-routing
R1(config)# exit
Configure Trunk-Based Inter-VLAN Routing:
R1(config)# interface g0/1.1
R1(config-subif)# encapsulation dot1Q 1
R1(config-subif)# ip address 192.168.1.1 255.255.255.0
R1(config-subif)# interface g0/1.10
R1(config-subif)# encapsulation dot1Q 10
R1(config-subif)# ip address 192.168.10.1 255.255.255.0
R1(config-subif)# interface g0/1.20
R1(config-subif)# encapsulation dot1Q 20
R1(config-subif)# ip address 192.168.20.1 255.255.255.0
R1(config-subif)# exit
R1(config)# interface g0/1
R1(config-if)# no shutdown
Configure IP settings on the routers:
R3(config)# interface s0/0/0
R3(config-if)# ip address 10.1.1.2 255.255.255.252
R3(config-if)# clock rate 128000
R3(config-if)# no shutdown
Configure RIPv2 routing:
R1# config t
R1(config)# router rip
R1(config-router)# version 2
R1(config-router)# passive-interface g0/1
R1(config-router)# network 172.30.0.0
R1(config-router)# network 10.0.0.0
Disable automatic summarization:
R1(config)# router rip
R1(config-router)# no auto-summary
Configure RIPng routing:
R1(config)# interface g0/1
R1(config)# ipv6 rip Test1 enable
R1(config)# interface s0/0/0
R1(config)# ipv6 rip Test1 enable
Configure and Verify OSPF Routing:
R1(config)# router ospf 1
R1(config-router)# network 192.168.1.0 0.0.0.255 area 0
R1(config-router)# network 192.168.12.0 0.0.0.3 area 0
R1(config-router)# network 192.168.13.0 0.0.0.3 area 0
Configure IPv6 Addresses Manually:
R1(config)# interface g0/0
R1(config-if)# ipv6 address 2001:db8:acad:a::1/64
R1(config-if)# no shutdown
R1(config-if)# interface g0/1
R1(config-if)# ipv6 address 2001:db8:acad:1::1/64
R1(config-if)# no shutdown
R1(config-if)# end
R1#
Configure OSPFv6:
R1(config)# interface g0/0
R1(config-if)# ipv6 ospf 1 area 0
R1(config-if)# interface s0/0/0
R1(config-if)# ipv6 ospf 1 area 0
R1(config-if)# interface s0/0/1
R1(config-if)# ipv6 ospf 1 area 0
Configure a numbered standard ACL:
R3(config)# access-list 1 remark Allow R1 LANs Access
R3(config)# access-list 1 permit 192.168.10.0 0.0.0.255
R3(config)# access-list 1 permit 192.168.20.0 0.0.0.255
R3(config)# access-list 1 deny any
R3(config)# interface g0/1
R3(config-if)# ip access-group 1 out
Configure a named extended ACL:
R3(config)# ip access-list extended WEB-POLICY
R3(config-ext-nacl)# permit tcp 192.168.30.0 0.0.0.255 host 10.1.1.1 eq 80
R3(config-ext-nacl)# permit tcp 192.168.30.0 0.0.0.255 209.165.200.224 0.0.0.31 eq 80
R3(config-ext-nacl)# interface S0/0/1
R3(config-if)# ip access-group WEB-POLICY out
Configuring Basic DHCPv4:
R1(config)# router eigrp 1
R1(config-router)# network 192.168.0.0 0.0.0.255
R1(config-router)# network 192.168.1.0 0.0.0.255
R1(config-router)# network 192.168.2.252 0.0.0.3
R1(config-router)# no auto-summary
DHCP Configuration:
R2(config)# ip dhcp excluded-address 192.168.0.1 192.168.0.9
R2(config)# ip dhcp excluded-address 192.168.1.1 192.168.1.9
R2(config)# ip dhcp pool R1G1
R2(dhcp-config)# network 192.168.1.0 255.255.255.0
R2(dhcp-config)# default-router 192.168.1.1
Configure HSRP:
R1(config)# interface g0/1
R1(config-if)# standby 1 ip 192.168.1.254
R1(config-if)# standby 1 priority 150
R1(config-if)# standby 1 preempt
Configure GLBP:
R1(config)# interface g0/1
R1(config-if)# glbp 1 ip 192.168.1.254
R1(config-if)# glbp 1 preempt
R1(config-if)# glbp 1 priority 150
R1(config-if)# glbp 1 load-balancing round-robin
Configure the ISP Router:
ISP(config)# username Cust1 password ciscopppoe
ISP(config)# ip local pool PPPoEPOOL 10.0.0.1 10.0.0.10
ISP(config)# interface virtual-template 1
ISP(config-if)# ip address 10.0.0.254 255.255.255.0
ISP(config-if)# mtu 1492
ISP(config-if)# peer default ip address pool PPPoEPOOL
ISP(config-if)# ppp authentication chap callin
ISP(config-if)# exit
Configure G0/0 interface as passive:
R1(config)# router eigrp 10
R1(config-router)# passive-interface g0/0
Configure EIGRP for IPv6 Routing
R1(config)# ipv6 router eigrp 1
R1(config-rtr)# router-id 1.1.1.1
Configure an SNMP agent:
R1(config)# snmp-server community ciscolab ro SNMP_ACL
R1(config)# snmp-server location snmp_manager
R1(config)# snmp-server contact ciscolab_admin
R1(config)# snmp-server host 192.168.1.3 version 2c ciscolab
R1(config)# snmp-server enable traps
R1(config)# ip access-list standard SNMP_ACL
R1(config-std-nacl)# permit 192.168.1.3
Ad

More Related Content

What's hot (20)

CCNA-LAB-GUIDE-V3_LAST-ADDITION (4).pdf
CCNA-LAB-GUIDE-V3_LAST-ADDITION (4).pdfCCNA-LAB-GUIDE-V3_LAST-ADDITION (4).pdf
CCNA-LAB-GUIDE-V3_LAST-ADDITION (4).pdf
poojaswami31
 
Ncat ccna cheat sheet
Ncat ccna cheat sheetNcat ccna cheat sheet
Ncat ccna cheat sheet
EZREIG OMAR
 
CCNA - Routing & Switching Commands
CCNA - Routing & Switching CommandsCCNA - Routing & Switching Commands
CCNA - Routing & Switching Commands
Eng. Emad Al-Atoum
 
Ccna command
Ccna commandCcna command
Ccna command
Siddhartha Rajbhatt
 
CCNA CheatSheet
CCNA CheatSheetCCNA CheatSheet
CCNA CheatSheet
Eng. Emad Al-Atoum
 
Cisco commands List for Beginners (CCNA, CCNP)
Cisco commands List for Beginners (CCNA, CCNP)Cisco commands List for Beginners (CCNA, CCNP)
Cisco commands List for Beginners (CCNA, CCNP)
DH Da Lat
 
How to configure vlan, stp, dtp step by step guide
How to configure vlan, stp, dtp step by step guideHow to configure vlan, stp, dtp step by step guide
How to configure vlan, stp, dtp step by step guide
IT Tech
 
Cisco Commands
Cisco CommandsCisco Commands
Cisco Commands
Fredrick Hall
 
Cisco router configuration tutorial
Cisco router configuration tutorialCisco router configuration tutorial
Cisco router configuration tutorial
IT Tech
 
IOS Cisco - Cheat sheets
IOS Cisco - Cheat sheetsIOS Cisco - Cheat sheets
IOS Cisco - Cheat sheets
Alejandro Marin
 
Router commands
Router commandsRouter commands
Router commands
Laura Lahbib
 
CCNA Lab Guide
CCNA Lab GuideCCNA Lab Guide
CCNA Lab Guide
Salachudin Emir
 
CCNA 2 Routing and Switching v5.0 Chapter 5
CCNA 2 Routing and Switching v5.0 Chapter 5CCNA 2 Routing and Switching v5.0 Chapter 5
CCNA 2 Routing and Switching v5.0 Chapter 5
Nil Menon
 
Libro cisco ios
Libro cisco iosLibro cisco ios
Libro cisco ios
Gabriel Andrés Riquelme Pérez
 
Lab6.4.1
Lab6.4.1Lab6.4.1
Lab6.4.1
Kanbuncha Panichcharoen
 
Cisco vs. huawei CLI Commands
Cisco vs. huawei CLI CommandsCisco vs. huawei CLI Commands
Cisco vs. huawei CLI Commands
Bootcamp SCL
 
CCNA 2 Routing and Switching v5.0 Chapter 6
CCNA 2 Routing and Switching v5.0 Chapter 6CCNA 2 Routing and Switching v5.0 Chapter 6
CCNA 2 Routing and Switching v5.0 Chapter 6
Nil Menon
 
CCNA 2 Routing and Switching v5.0 Chapter 10
CCNA 2 Routing and Switching v5.0 Chapter 10CCNA 2 Routing and Switching v5.0 Chapter 10
CCNA 2 Routing and Switching v5.0 Chapter 10
Nil Menon
 
Chapter 8 - IP Subnetting, Troubleshooting and Introduction to NAT 9e
Chapter 8 - IP Subnetting, Troubleshooting and Introduction to NAT 9eChapter 8 - IP Subnetting, Troubleshooting and Introduction to NAT 9e
Chapter 8 - IP Subnetting, Troubleshooting and Introduction to NAT 9e
adpeer
 
Chapter 14 : vlan
Chapter 14 : vlanChapter 14 : vlan
Chapter 14 : vlan
teknetir
 
CCNA-LAB-GUIDE-V3_LAST-ADDITION (4).pdf
CCNA-LAB-GUIDE-V3_LAST-ADDITION (4).pdfCCNA-LAB-GUIDE-V3_LAST-ADDITION (4).pdf
CCNA-LAB-GUIDE-V3_LAST-ADDITION (4).pdf
poojaswami31
 
Ncat ccna cheat sheet
Ncat ccna cheat sheetNcat ccna cheat sheet
Ncat ccna cheat sheet
EZREIG OMAR
 
CCNA - Routing & Switching Commands
CCNA - Routing & Switching CommandsCCNA - Routing & Switching Commands
CCNA - Routing & Switching Commands
Eng. Emad Al-Atoum
 
Cisco commands List for Beginners (CCNA, CCNP)
Cisco commands List for Beginners (CCNA, CCNP)Cisco commands List for Beginners (CCNA, CCNP)
Cisco commands List for Beginners (CCNA, CCNP)
DH Da Lat
 
How to configure vlan, stp, dtp step by step guide
How to configure vlan, stp, dtp step by step guideHow to configure vlan, stp, dtp step by step guide
How to configure vlan, stp, dtp step by step guide
IT Tech
 
Cisco router configuration tutorial
Cisco router configuration tutorialCisco router configuration tutorial
Cisco router configuration tutorial
IT Tech
 
IOS Cisco - Cheat sheets
IOS Cisco - Cheat sheetsIOS Cisco - Cheat sheets
IOS Cisco - Cheat sheets
Alejandro Marin
 
CCNA 2 Routing and Switching v5.0 Chapter 5
CCNA 2 Routing and Switching v5.0 Chapter 5CCNA 2 Routing and Switching v5.0 Chapter 5
CCNA 2 Routing and Switching v5.0 Chapter 5
Nil Menon
 
Cisco vs. huawei CLI Commands
Cisco vs. huawei CLI CommandsCisco vs. huawei CLI Commands
Cisco vs. huawei CLI Commands
Bootcamp SCL
 
CCNA 2 Routing and Switching v5.0 Chapter 6
CCNA 2 Routing and Switching v5.0 Chapter 6CCNA 2 Routing and Switching v5.0 Chapter 6
CCNA 2 Routing and Switching v5.0 Chapter 6
Nil Menon
 
CCNA 2 Routing and Switching v5.0 Chapter 10
CCNA 2 Routing and Switching v5.0 Chapter 10CCNA 2 Routing and Switching v5.0 Chapter 10
CCNA 2 Routing and Switching v5.0 Chapter 10
Nil Menon
 
Chapter 8 - IP Subnetting, Troubleshooting and Introduction to NAT 9e
Chapter 8 - IP Subnetting, Troubleshooting and Introduction to NAT 9eChapter 8 - IP Subnetting, Troubleshooting and Introduction to NAT 9e
Chapter 8 - IP Subnetting, Troubleshooting and Introduction to NAT 9e
adpeer
 
Chapter 14 : vlan
Chapter 14 : vlanChapter 14 : vlan
Chapter 14 : vlan
teknetir
 

Similar to Basic cisco commands_by_marcus_nielson_2 (20)

cisco ccna cheat_sheet
cisco ccna cheat_sheetcisco ccna cheat_sheet
cisco ccna cheat_sheet
Guntaka Reddy
 
Aula04 - configuração da topologia ppp - resolvido
Aula04 -  configuração da topologia ppp - resolvidoAula04 -  configuração da topologia ppp - resolvido
Aula04 - configuração da topologia ppp - resolvido
Carlos Veiga
 
labffbhhhhjjjjjjjjj bnbbnv material.pptx
labffbhhhhjjjjjjjjj bnbbnv material.pptxlabffbhhhhjjjjjjjjj bnbbnv material.pptx
labffbhhhhjjjjjjjjj bnbbnv material.pptx
BinyamBekeleMoges
 
Ccna commands
Ccna commandsCcna commands
Ccna commands
Hajji Mboowa Yahaya
 
Ccna commands
Ccna commandsCcna commands
Ccna commands
Hajji Mboowa Yahaya
 
OSWAN.pptx
OSWAN.pptxOSWAN.pptx
OSWAN.pptx
BiswajitSahoo339348
 
CCNA presentation.
CCNA presentation.CCNA presentation.
CCNA presentation.
Ajaigururaj R
 
Configuración del dial peer
Configuración del dial peer Configuración del dial peer
Configuración del dial peer
miguelangelperezhenao
 
Ccnacommand 140205001152-phpapp01
Ccnacommand 140205001152-phpapp01Ccnacommand 140205001152-phpapp01
Ccnacommand 140205001152-phpapp01
A.S.M Shmimul Islam.
 
Ccna commands
Ccna commands   Ccna commands
Ccna commands
bunthon oun
 
Ccna command
Ccna commandCcna command
Ccna command
Sudhir Maherwal
 
Packet Tracer da Cisco (Configuração Básica) Professor Fernando Maviuco - 202...
Packet Tracer da Cisco (Configuração Básica) Professor Fernando Maviuco - 202...Packet Tracer da Cisco (Configuração Básica) Professor Fernando Maviuco - 202...
Packet Tracer da Cisco (Configuração Básica) Professor Fernando Maviuco - 202...
Editora
 
How to Configure Routing Information Protocol (RIP)
How to Configure Routing Information Protocol (RIP)How to Configure Routing Information Protocol (RIP)
How to Configure Routing Information Protocol (RIP)
IT Tech
 
Labmannual
LabmannualLabmannual
Labmannual
Matiullah Jamil
 
Cisco Router Basic Configuraiton
Cisco Router Basic ConfiguraitonCisco Router Basic Configuraiton
Cisco Router Basic Configuraiton
Kadir CIKIS
 
OSPF (open shortest path first) part iii
OSPF (open shortest path first) part  iiiOSPF (open shortest path first) part  iii
OSPF (open shortest path first) part iii
Netwax Lab
 
Dynamic routing OSPF 1
Dynamic routing OSPF 1Dynamic routing OSPF 1
Dynamic routing OSPF 1
Kishore Kumar
 
CCNA ppt Day 4
CCNA ppt Day 4CCNA ppt Day 4
CCNA ppt Day 4
VISHNU N
 
How to configure frame realy
How to configure frame realyHow to configure frame realy
How to configure frame realy
NetProtocol Xpert
 
Service Provider Networks and Frame Relay
Service Provider Networks and Frame RelayService Provider Networks and Frame Relay
Service Provider Networks and Frame Relay
Tharindu Sankalpa
 
cisco ccna cheat_sheet
cisco ccna cheat_sheetcisco ccna cheat_sheet
cisco ccna cheat_sheet
Guntaka Reddy
 
Aula04 - configuração da topologia ppp - resolvido
Aula04 -  configuração da topologia ppp - resolvidoAula04 -  configuração da topologia ppp - resolvido
Aula04 - configuração da topologia ppp - resolvido
Carlos Veiga
 
labffbhhhhjjjjjjjjj bnbbnv material.pptx
labffbhhhhjjjjjjjjj bnbbnv material.pptxlabffbhhhhjjjjjjjjj bnbbnv material.pptx
labffbhhhhjjjjjjjjj bnbbnv material.pptx
BinyamBekeleMoges
 
Packet Tracer da Cisco (Configuração Básica) Professor Fernando Maviuco - 202...
Packet Tracer da Cisco (Configuração Básica) Professor Fernando Maviuco - 202...Packet Tracer da Cisco (Configuração Básica) Professor Fernando Maviuco - 202...
Packet Tracer da Cisco (Configuração Básica) Professor Fernando Maviuco - 202...
Editora
 
How to Configure Routing Information Protocol (RIP)
How to Configure Routing Information Protocol (RIP)How to Configure Routing Information Protocol (RIP)
How to Configure Routing Information Protocol (RIP)
IT Tech
 
Cisco Router Basic Configuraiton
Cisco Router Basic ConfiguraitonCisco Router Basic Configuraiton
Cisco Router Basic Configuraiton
Kadir CIKIS
 
OSPF (open shortest path first) part iii
OSPF (open shortest path first) part  iiiOSPF (open shortest path first) part  iii
OSPF (open shortest path first) part iii
Netwax Lab
 
Dynamic routing OSPF 1
Dynamic routing OSPF 1Dynamic routing OSPF 1
Dynamic routing OSPF 1
Kishore Kumar
 
CCNA ppt Day 4
CCNA ppt Day 4CCNA ppt Day 4
CCNA ppt Day 4
VISHNU N
 
How to configure frame realy
How to configure frame realyHow to configure frame realy
How to configure frame realy
NetProtocol Xpert
 
Service Provider Networks and Frame Relay
Service Provider Networks and Frame RelayService Provider Networks and Frame Relay
Service Provider Networks and Frame Relay
Tharindu Sankalpa
 
Ad

Recently uploaded (20)

Com fer un pla de gestió de dades amb l'eiNa DMP (en anglès)
Com fer un pla de gestió de dades amb l'eiNa DMP (en anglès)Com fer un pla de gestió de dades amb l'eiNa DMP (en anglès)
Com fer un pla de gestió de dades amb l'eiNa DMP (en anglès)
CSUC - Consorci de Serveis Universitaris de Catalunya
 
DevOpsDays SLC - Platform Engineers are Product Managers.pptx
DevOpsDays SLC - Platform Engineers are Product Managers.pptxDevOpsDays SLC - Platform Engineers are Product Managers.pptx
DevOpsDays SLC - Platform Engineers are Product Managers.pptx
Justin Reock
 
machines-for-woodworking-shops-en-compressed.pdf
machines-for-woodworking-shops-en-compressed.pdfmachines-for-woodworking-shops-en-compressed.pdf
machines-for-woodworking-shops-en-compressed.pdf
AmirStern2
 
Config 2025 presentation recap covering both days
Config 2025 presentation recap covering both daysConfig 2025 presentation recap covering both days
Config 2025 presentation recap covering both days
TrishAntoni1
 
Building the Customer Identity Community, Together.pdf
Building the Customer Identity Community, Together.pdfBuilding the Customer Identity Community, Together.pdf
Building the Customer Identity Community, Together.pdf
Cheryl Hung
 
Build With AI - In Person Session Slides.pdf
Build With AI - In Person Session Slides.pdfBuild With AI - In Person Session Slides.pdf
Build With AI - In Person Session Slides.pdf
Google Developer Group - Harare
 
Limecraft Webinar - 2025.3 release, featuring Content Delivery, Graphic Conte...
Limecraft Webinar - 2025.3 release, featuring Content Delivery, Graphic Conte...Limecraft Webinar - 2025.3 release, featuring Content Delivery, Graphic Conte...
Limecraft Webinar - 2025.3 release, featuring Content Delivery, Graphic Conte...
Maarten Verwaest
 
Zilliz Cloud Monthly Technical Review: May 2025
Zilliz Cloud Monthly Technical Review: May 2025Zilliz Cloud Monthly Technical Review: May 2025
Zilliz Cloud Monthly Technical Review: May 2025
Zilliz
 
Top 5 Benefits of Using Molybdenum Rods in Industrial Applications.pptx
Top 5 Benefits of Using Molybdenum Rods in Industrial Applications.pptxTop 5 Benefits of Using Molybdenum Rods in Industrial Applications.pptx
Top 5 Benefits of Using Molybdenum Rods in Industrial Applications.pptx
mkubeusa
 
Kit-Works Team Study_아직도 Dockefile.pdf_김성호
Kit-Works Team Study_아직도 Dockefile.pdf_김성호Kit-Works Team Study_아직도 Dockefile.pdf_김성호
Kit-Works Team Study_아직도 Dockefile.pdf_김성호
Wonjun Hwang
 
UiPath Automation Suite – Cas d'usage d'une NGO internationale basée à Genève
UiPath Automation Suite – Cas d'usage d'une NGO internationale basée à GenèveUiPath Automation Suite – Cas d'usage d'une NGO internationale basée à Genève
UiPath Automation Suite – Cas d'usage d'une NGO internationale basée à Genève
UiPathCommunity
 
Cybersecurity Threat Vectors and Mitigation
Cybersecurity Threat Vectors and MitigationCybersecurity Threat Vectors and Mitigation
Cybersecurity Threat Vectors and Mitigation
VICTOR MAESTRE RAMIREZ
 
IT488 Wireless Sensor Networks_Information Technology
IT488 Wireless Sensor Networks_Information TechnologyIT488 Wireless Sensor Networks_Information Technology
IT488 Wireless Sensor Networks_Information Technology
SHEHABALYAMANI
 
Integrating FME with Python: Tips, Demos, and Best Practices for Powerful Aut...
Integrating FME with Python: Tips, Demos, and Best Practices for Powerful Aut...Integrating FME with Python: Tips, Demos, and Best Practices for Powerful Aut...
Integrating FME with Python: Tips, Demos, and Best Practices for Powerful Aut...
Safe Software
 
Mastering Testing in the Modern F&B Landscape
Mastering Testing in the Modern F&B LandscapeMastering Testing in the Modern F&B Landscape
Mastering Testing in the Modern F&B Landscape
marketing943205
 
RTP Over QUIC: An Interesting Opportunity Or Wasted Time?
RTP Over QUIC: An Interesting Opportunity Or Wasted Time?RTP Over QUIC: An Interesting Opportunity Or Wasted Time?
RTP Over QUIC: An Interesting Opportunity Or Wasted Time?
Lorenzo Miniero
 
Could Virtual Threads cast away the usage of Kotlin Coroutines - DevoxxUK2025
Could Virtual Threads cast away the usage of Kotlin Coroutines - DevoxxUK2025Could Virtual Threads cast away the usage of Kotlin Coroutines - DevoxxUK2025
Could Virtual Threads cast away the usage of Kotlin Coroutines - DevoxxUK2025
João Esperancinha
 
Crazy Incentives and How They Kill Security. How Do You Turn the Wheel?
Crazy Incentives and How They Kill Security. How Do You Turn the Wheel?Crazy Incentives and How They Kill Security. How Do You Turn the Wheel?
Crazy Incentives and How They Kill Security. How Do You Turn the Wheel?
Christian Folini
 
Enterprise Integration Is Dead! Long Live AI-Driven Integration with Apache C...
Enterprise Integration Is Dead! Long Live AI-Driven Integration with Apache C...Enterprise Integration Is Dead! Long Live AI-Driven Integration with Apache C...
Enterprise Integration Is Dead! Long Live AI-Driven Integration with Apache C...
Markus Eisele
 
Everything You Need to Know About Agentforce? (Put AI Agents to Work)
Everything You Need to Know About Agentforce? (Put AI Agents to Work)Everything You Need to Know About Agentforce? (Put AI Agents to Work)
Everything You Need to Know About Agentforce? (Put AI Agents to Work)
Cyntexa
 
DevOpsDays SLC - Platform Engineers are Product Managers.pptx
DevOpsDays SLC - Platform Engineers are Product Managers.pptxDevOpsDays SLC - Platform Engineers are Product Managers.pptx
DevOpsDays SLC - Platform Engineers are Product Managers.pptx
Justin Reock
 
machines-for-woodworking-shops-en-compressed.pdf
machines-for-woodworking-shops-en-compressed.pdfmachines-for-woodworking-shops-en-compressed.pdf
machines-for-woodworking-shops-en-compressed.pdf
AmirStern2
 
Config 2025 presentation recap covering both days
Config 2025 presentation recap covering both daysConfig 2025 presentation recap covering both days
Config 2025 presentation recap covering both days
TrishAntoni1
 
Building the Customer Identity Community, Together.pdf
Building the Customer Identity Community, Together.pdfBuilding the Customer Identity Community, Together.pdf
Building the Customer Identity Community, Together.pdf
Cheryl Hung
 
Limecraft Webinar - 2025.3 release, featuring Content Delivery, Graphic Conte...
Limecraft Webinar - 2025.3 release, featuring Content Delivery, Graphic Conte...Limecraft Webinar - 2025.3 release, featuring Content Delivery, Graphic Conte...
Limecraft Webinar - 2025.3 release, featuring Content Delivery, Graphic Conte...
Maarten Verwaest
 
Zilliz Cloud Monthly Technical Review: May 2025
Zilliz Cloud Monthly Technical Review: May 2025Zilliz Cloud Monthly Technical Review: May 2025
Zilliz Cloud Monthly Technical Review: May 2025
Zilliz
 
Top 5 Benefits of Using Molybdenum Rods in Industrial Applications.pptx
Top 5 Benefits of Using Molybdenum Rods in Industrial Applications.pptxTop 5 Benefits of Using Molybdenum Rods in Industrial Applications.pptx
Top 5 Benefits of Using Molybdenum Rods in Industrial Applications.pptx
mkubeusa
 
Kit-Works Team Study_아직도 Dockefile.pdf_김성호
Kit-Works Team Study_아직도 Dockefile.pdf_김성호Kit-Works Team Study_아직도 Dockefile.pdf_김성호
Kit-Works Team Study_아직도 Dockefile.pdf_김성호
Wonjun Hwang
 
UiPath Automation Suite – Cas d'usage d'une NGO internationale basée à Genève
UiPath Automation Suite – Cas d'usage d'une NGO internationale basée à GenèveUiPath Automation Suite – Cas d'usage d'une NGO internationale basée à Genève
UiPath Automation Suite – Cas d'usage d'une NGO internationale basée à Genève
UiPathCommunity
 
Cybersecurity Threat Vectors and Mitigation
Cybersecurity Threat Vectors and MitigationCybersecurity Threat Vectors and Mitigation
Cybersecurity Threat Vectors and Mitigation
VICTOR MAESTRE RAMIREZ
 
IT488 Wireless Sensor Networks_Information Technology
IT488 Wireless Sensor Networks_Information TechnologyIT488 Wireless Sensor Networks_Information Technology
IT488 Wireless Sensor Networks_Information Technology
SHEHABALYAMANI
 
Integrating FME with Python: Tips, Demos, and Best Practices for Powerful Aut...
Integrating FME with Python: Tips, Demos, and Best Practices for Powerful Aut...Integrating FME with Python: Tips, Demos, and Best Practices for Powerful Aut...
Integrating FME with Python: Tips, Demos, and Best Practices for Powerful Aut...
Safe Software
 
Mastering Testing in the Modern F&B Landscape
Mastering Testing in the Modern F&B LandscapeMastering Testing in the Modern F&B Landscape
Mastering Testing in the Modern F&B Landscape
marketing943205
 
RTP Over QUIC: An Interesting Opportunity Or Wasted Time?
RTP Over QUIC: An Interesting Opportunity Or Wasted Time?RTP Over QUIC: An Interesting Opportunity Or Wasted Time?
RTP Over QUIC: An Interesting Opportunity Or Wasted Time?
Lorenzo Miniero
 
Could Virtual Threads cast away the usage of Kotlin Coroutines - DevoxxUK2025
Could Virtual Threads cast away the usage of Kotlin Coroutines - DevoxxUK2025Could Virtual Threads cast away the usage of Kotlin Coroutines - DevoxxUK2025
Could Virtual Threads cast away the usage of Kotlin Coroutines - DevoxxUK2025
João Esperancinha
 
Crazy Incentives and How They Kill Security. How Do You Turn the Wheel?
Crazy Incentives and How They Kill Security. How Do You Turn the Wheel?Crazy Incentives and How They Kill Security. How Do You Turn the Wheel?
Crazy Incentives and How They Kill Security. How Do You Turn the Wheel?
Christian Folini
 
Enterprise Integration Is Dead! Long Live AI-Driven Integration with Apache C...
Enterprise Integration Is Dead! Long Live AI-Driven Integration with Apache C...Enterprise Integration Is Dead! Long Live AI-Driven Integration with Apache C...
Enterprise Integration Is Dead! Long Live AI-Driven Integration with Apache C...
Markus Eisele
 
Everything You Need to Know About Agentforce? (Put AI Agents to Work)
Everything You Need to Know About Agentforce? (Put AI Agents to Work)Everything You Need to Know About Agentforce? (Put AI Agents to Work)
Everything You Need to Know About Agentforce? (Put AI Agents to Work)
Cyntexa
 
Ad

Basic cisco commands_by_marcus_nielson_2

  • 1. Basic Cisco Commands By Marcus Nielson (2014) Configuring Basic Switch Settings (Switch Examples) Enter enable if the prompt has changed back to Switch>. Switch> enable Switch# Enter global configuration mode. Switch# configure terminal Enter configuration commands, one per line. End with CNTL/Z. Switch(config)# The prompt changed again to reflect global configuration mode. Assign the switch hostname. Switch(config)# hostname S1 S1(config)# Configure password encryption. S1(config)# service password-encryption S1(config)# Assign class as the secret password for privileged EXEC mode access. S1(config)# enable secret class S1(config)# Prevent unwanted DNS lookups. S1(config)# no ip domain-lookup S1(config)# Configure a MOTD banner. S1(config)# banner motd # Enter Text message. End with the character ‘#’. Unauthorized access is strictly prohibited. # Verify your access settings by moving between modes. S1(config)# exit S1# *Mar 1 00:19:19.490: %SYS-5-CONFIG_I: Configured from console by console S1# exit
  • 2. S1 con0 is now available. Creating/Assigning a VLAN IP Address Example: S1(config)# vlan 99 S1(config-vlan)# name (name of VLAN) S1(config-vlan)# exit S1(config)# Configure the VLAN 99 IP address: S1(config)# interface vlan 99 S1(config-if)# ip address 172.16.99.11 255.255.255.0 S1(config-if)# no shutdown S1(config-if)# end S1# Configuring IP Default Gateway: S1(config)# ip default-gateway 192.168.1.1 S1(config)# Restrict Access: S1(config)# line con 0 S1(config-line)# password (pw) S1(config-line)# login S1(config-line)# logging synchronous S1(config-line)# exit S1(config)# VTY: S1(config)# line vty 0 15 S1(config-line)# password (pw) S1(config-line)# login S1(config-line)# end S1# Assign ports F0/5 and F0/6 to VLAN 99 on the switch: S1# config t S1(config)# interface f0/5 S1(config-if)# switchport mode access S1(config-if)# switchport access vlan 99 S1(config-if)# interface f0/6 S1(config-if)# switchport mode access S1(config-if)# switchport access vlan 99 S1(config-if)# end Assigning ports to VLAN (range):
  • 3. S1(config)# interface range f0/1 – 24,g0/1 - 2 S1(config-if-range)# switchport access vlan # S1(config-if-range)# exit S1(config)# end Configure and Verify SSH: S1(config)# line vty 0 15 S1(config-line)# transport input ssh S1(config-line)# login local S1(config-line)# exit Generate an RSA crypto keys: S1(config)# crypto key generate rsa modulus 1024 Configure general security features: S1(config)# interface range f0/1 – 4 S1(config-if-range)# shutdown S1(config-if-range)# interface range f0/7 – 24 S1(config-if-range)# shutdown S1(config-if-range)# interface range g0/1 – 2 S1(config-if-range)# shutdown S1(config-if-range)# end S1# Enter local passwords: S1(config)# enable secret class S1(config)# line con 0 S1(config-line)# password (pw) S1(config-line)# login S1(config-line)# exit S1(config)# Configure a trunk port: S2(config)# interface f0/1 S2(config-if)# switchport mode trunk S1# show interface trunk Configuring 802.1Q Trunk-Based Inter-VLAN Routing: S1(config)# vlan 10 S1(config-vlan)# name Students S1(config-vlan)# vlan 20 S1(config-vlan)# name Faculty S1(config-vlan)# exit S1(config)# interface f0/1 S1(config-if)# switchport mode trunk
  • 4. S1(config-if)# interface f0/5 S1(config-if)# switchport mode trunk S1(config-if)# interface f0/6 S1(config-if)# switchport mode access S1(config-if)# switchport access vlan 10 Configure DHCPv4 : S1(config)# ip dhcp excluded-address 192.168.1.1 192.168.1.10 S1(config)# ip dhcp pool DHCP1 S1(dhcp-config)# network 192.168.1.0 255.255.255.0 S1(dhcp-config)# default-router 192.168.1.1 S1(dhcp-config)# dns-server 192.168.1.9 S1(dhcp-config)# lease 3 Configure DHCPv4 for Multiple VLANs: S1(config)# interface f0/6 S1(config-if)# switchport access vlan 2 S1(config)# ip dhcp excluded-address 192.168.2.1 192.168.2.10 S1(config)# ip dhcp pool DHCP2 S1(dhcp-config)# network 192.168.2.0 255.255.255.0 S1(dhcp-config)# default-router 192.168.2.1 S1(dhcp-config)# dns-server 192.168.2.9 S1(dhcp-config)# lease 3 Enable IP Routing: S1(config)# ip routing S1(config)# ip route 0.0.0.0 0.0.0.0 192.168.1.10 R1(config)# ip route 192.168.2.0 255.255.255.0 g0/1 Enable spanning-tree, rapid-pvst, portfast: S1(config)# spanning-tree vlan 1,10,99 root secondary S1(config)# spanning-tree mode rapid-pvst S1(config)# interface f0/6 S1(config-if)# spanning-tree portfast S1(config-if)# spanning-tree bpduguard enable Configure PAgP: S1(config)# interface range f0/3-4 S1(config-if-range)# channel-group 1 mode desirable Creating a port-channel interface Port-channel 1 S1(config-if-range)# no shutdown Configure trunk ports assign to VLAN:
  • 5. S1(config)# interface port-channel 1 S1(config-if)# switchport mode trunk S1(config-if)# switchport trunk native vlan 99 Delete the VLAN database: S1# delete vlan.dat Delete filename [vlan.dat]? Delete flash:/vlan.dat? [confirm] S1# Configuring Basic Router Settings (Router Examples) ========================== Configure the router: Router> enable Router# Router# config terminal Router(config)# Router(config)#  hostname  R1.     R1(config)#  no  ip  domain-­‐lookup    R1(config)#  security  passwords  min-­‐length  10       R1(config)#  enable  secret  cisco12345   Setting a console password on a router: R1(config)# line con 0 R1(config-line)# password ciscoconpass R1(config-line)# exec-timeout 5 0 R1(config-line)# login R1(config-line)# logging synchronous R1(config-line)# exit R1(config)# Assign VTY password: R1(config)# line vty 0 4 R1(config-line)# password ciscovtypass R1(config-line)# exec-timeout 5 0 R1(config-line)# login R1(config-line)# logging synchronous R1(config-line)# exit R1(config)# Encrypt the clear text passwords: R1(config)# service password-encryption
  • 6. Create a MOTD banner: R1(config)# banner motd #Unauthorized access prohibited!# Configure an IP address and interface description. Activate both interfaces on the router: R1(config)# int g0/0 R1(config-if)# description Connection to PC-B R1(config-if)# ip address 192.168.0.1 255.255.255.0 R1(config-if)# no shutdown R1(config-if)# int g0/1 R1(config-if)# description Connection to S1 R1(config-if)# ip address 192.168.1.1 255.255.255.0 R1(config-if)# no shutdown R1(config-if)# exit Configure the router for SSH access: R1# configure terminal R1(config)# ip domain-name CCNA-lab.com R1(config)# username admin privilege 15 secret adminpass1 R1(config)# line vty 0 4 R1(config-line)# transport input ssh R1(config-line)# login local R1(config-line)# exit R1(config)# crypto key generate rsa modulus 1024 R1(config)# exit Configure IPv6: R1# configure terminal R1(config)# interface g0/0 R1(config-if)# ipv6 address 2001:db8:acad:a::1/64 R1(config-if)# ipv6 address fe80::1 link-local R1(config-if)# no shutdown R1(config-if)# exit R1(config)# ipv6 unicast-routing R1(config)# exit Configure Trunk-Based Inter-VLAN Routing: R1(config)# interface g0/1.1 R1(config-subif)# encapsulation dot1Q 1 R1(config-subif)# ip address 192.168.1.1 255.255.255.0 R1(config-subif)# interface g0/1.10 R1(config-subif)# encapsulation dot1Q 10 R1(config-subif)# ip address 192.168.10.1 255.255.255.0 R1(config-subif)# interface g0/1.20 R1(config-subif)# encapsulation dot1Q 20 R1(config-subif)# ip address 192.168.20.1 255.255.255.0 R1(config-subif)# exit R1(config)# interface g0/1
  • 7. R1(config-if)# no shutdown Configure IP settings on the routers: R3(config)# interface s0/0/0 R3(config-if)# ip address 10.1.1.2 255.255.255.252 R3(config-if)# clock rate 128000 R3(config-if)# no shutdown Configure RIPv2 routing: R1# config t R1(config)# router rip R1(config-router)# version 2 R1(config-router)# passive-interface g0/1 R1(config-router)# network 172.30.0.0 R1(config-router)# network 10.0.0.0 Disable automatic summarization: R1(config)# router rip R1(config-router)# no auto-summary Configure RIPng routing: R1(config)# interface g0/1 R1(config)# ipv6 rip Test1 enable R1(config)# interface s0/0/0 R1(config)# ipv6 rip Test1 enable Configure and Verify OSPF Routing: R1(config)# router ospf 1 R1(config-router)# network 192.168.1.0 0.0.0.255 area 0 R1(config-router)# network 192.168.12.0 0.0.0.3 area 0 R1(config-router)# network 192.168.13.0 0.0.0.3 area 0 Configure IPv6 Addresses Manually: R1(config)# interface g0/0 R1(config-if)# ipv6 address 2001:db8:acad:a::1/64 R1(config-if)# no shutdown R1(config-if)# interface g0/1 R1(config-if)# ipv6 address 2001:db8:acad:1::1/64 R1(config-if)# no shutdown R1(config-if)# end R1# Configure OSPFv6: R1(config)# interface g0/0
  • 8. R1(config-if)# ipv6 ospf 1 area 0 R1(config-if)# interface s0/0/0 R1(config-if)# ipv6 ospf 1 area 0 R1(config-if)# interface s0/0/1 R1(config-if)# ipv6 ospf 1 area 0 Configure a numbered standard ACL: R3(config)# access-list 1 remark Allow R1 LANs Access R3(config)# access-list 1 permit 192.168.10.0 0.0.0.255 R3(config)# access-list 1 permit 192.168.20.0 0.0.0.255 R3(config)# access-list 1 deny any R3(config)# interface g0/1 R3(config-if)# ip access-group 1 out Configure a named extended ACL: R3(config)# ip access-list extended WEB-POLICY R3(config-ext-nacl)# permit tcp 192.168.30.0 0.0.0.255 host 10.1.1.1 eq 80 R3(config-ext-nacl)# permit tcp 192.168.30.0 0.0.0.255 209.165.200.224 0.0.0.31 eq 80 R3(config-ext-nacl)# interface S0/0/1 R3(config-if)# ip access-group WEB-POLICY out Configuring Basic DHCPv4: R1(config)# router eigrp 1 R1(config-router)# network 192.168.0.0 0.0.0.255 R1(config-router)# network 192.168.1.0 0.0.0.255 R1(config-router)# network 192.168.2.252 0.0.0.3 R1(config-router)# no auto-summary DHCP Configuration: R2(config)# ip dhcp excluded-address 192.168.0.1 192.168.0.9 R2(config)# ip dhcp excluded-address 192.168.1.1 192.168.1.9 R2(config)# ip dhcp pool R1G1 R2(dhcp-config)# network 192.168.1.0 255.255.255.0 R2(dhcp-config)# default-router 192.168.1.1 Configure HSRP: R1(config)# interface g0/1 R1(config-if)# standby 1 ip 192.168.1.254 R1(config-if)# standby 1 priority 150 R1(config-if)# standby 1 preempt Configure GLBP: R1(config)# interface g0/1 R1(config-if)# glbp 1 ip 192.168.1.254
  • 9. R1(config-if)# glbp 1 preempt R1(config-if)# glbp 1 priority 150 R1(config-if)# glbp 1 load-balancing round-robin Configure the ISP Router: ISP(config)# username Cust1 password ciscopppoe ISP(config)# ip local pool PPPoEPOOL 10.0.0.1 10.0.0.10 ISP(config)# interface virtual-template 1 ISP(config-if)# ip address 10.0.0.254 255.255.255.0 ISP(config-if)# mtu 1492 ISP(config-if)# peer default ip address pool PPPoEPOOL ISP(config-if)# ppp authentication chap callin ISP(config-if)# exit Configure G0/0 interface as passive: R1(config)# router eigrp 10 R1(config-router)# passive-interface g0/0 Configure EIGRP for IPv6 Routing R1(config)# ipv6 router eigrp 1 R1(config-rtr)# router-id 1.1.1.1 Configure an SNMP agent: R1(config)# snmp-server community ciscolab ro SNMP_ACL R1(config)# snmp-server location snmp_manager R1(config)# snmp-server contact ciscolab_admin R1(config)# snmp-server host 192.168.1.3 version 2c ciscolab R1(config)# snmp-server enable traps R1(config)# ip access-list standard SNMP_ACL R1(config-std-nacl)# permit 192.168.1.3
  翻译: