How would you approach this problem? Comment your answer



Consider a list (list = []). You can perform the following commands:

  1. insert i e: Insert integer at position .
  2. print: Print the list.
  3. remove e: Delete the first occurrence of integer .
  4. append e: Insert integer at the end of the list.
  5. sort: Sort the list.
  6. pop: Pop the last element from the list.
  7. reverse: Reverse the list.

Initialize your list and read in the value of followed by lines of commands where each command will be of the types listed above. Iterate through each command in order and perform the corresponding operation on your list.

Example

  • : Append to the list, .
  • : Append to the list, .
  • : Insert at index , .
  • : Print the array. Output:

[1, 3, 2]
        

Input Format

The first line contains an integer, , denoting the number of commands. Each line of the subsequent lines contains one of the commands described above.

Constraints

  • The elements added to the list must be integers.

Output Format

For each command of type print, print the list on a new line.

Sample Input 0

12
insert 0 5
insert 1 10
insert 0 6
print
remove 6
append 9
append 1
sort
print
pop
reverse
print
        

Sample Output 0

[6, 5, 10]
[1, 5, 9, 10]
[9, 5, 1]
        



To view or add a comment, sign in

More articles by KUNAL V.

  • Problem of the Day

    We have seen that lists are mutable (they can be changed), and tuples are immutable (they cannot be changed). Let's try…

  • Solution of the Day

    def print_full_name(first, last): # Write your code here string = "Hello"+" "+first+" "+last+"! You just delved into…

  • Solution of the Day

    def split_and_join(line): # write your code here line = line.split(" ") line = "-".

  • Problem of The Day

    You are given a string and your task is to swap cases. In other words, convert all lowercase letters to uppercase…

  • Problem of the Day

    Print the following pattern Write a program to print the following start pattern using the loop Solution for the same…

  • Solution of The Day

    if name == '__main__': n = int(input()) integer_list = tuple(map(int, input().split())) has_value = hash(integer_list)…

  • Solve this Problem

    Given an integer, , and space-separated integers as input, create a tuple, , of those integers. Then compute and print…

  • Answer For Today's Coding Problem

    if name == '__main__': # Read the number of operations N = int(input()) # Initialize an empty list L = [] # Loop…

  • Python Problem Solving

    2/ 30 Day Solution #python #pythonproblemsolving #30daycodingchallenge #30daychallenge #problemsolving if name ==…

Insights from the community

Others also viewed

Explore topics